MPLS VPN Inter-AS Option B

默认前提是AS内部的IGP,BGP和LDP都配置了。中间P设备不运行BGP。ASBR上没有VRF。而与Option A的区别就是ASBR之间传递的也是标签包。Option A里,ASBR之间是通过VRF的接口互相将另一个AS看作为一个CE,因为之间传递的是IP包

1. PE-CE协议

常用的协议有:

  • 静态
  • OSPF
  • BGP

当然也可以RIP或EIGRP。具体是在CE上正常配置路由协议。在PE上建立客户的VRF,并在VRF运行路由协议。

使用OSPF传递路由

CE1
router ospf 1
  router-id 1.1.1.1
interface Ethernet0/0
  ip address 192.168.0.1 255.255.255.0
  ip ospf 1 area 0

PE1 
vrf office
  address-family ipv4 unicast
   import route-target
    100:1
    200:1
   export route-target
    100:1
interface GigabitEthernet0/0/0/1
  vrf office
  ipv4 address 192.168.0.3 255.255.255.0
router ospf 1
  vrf office
   address-family ipv4 unicast
   area 0
    interface GigabitEthernet0/0/0/1

使用静态传递路由

CE2
ip route 0.0.0.0 0.0.0.0 192.168.0.4
interface Ethernet0/0
  ip address 192.168.0.2 255.255.255.0

PE2
vrf office
  address-family ipv4 unicast
   import route-target
    100:1
    200:1
   export route-target
    100:1
interface GigabitEthernet0/0/0/1
  vrf office
  ipv4 address 192.168.0.4 255.255.255.0
router static
  vrf office
   address-family ipv4 unicast
    2.2.2.2/32 192.168.0.2

2. IGP和BGP互相重分布

在VRF内将BGP和IGP互相导入。

PE1
router ospf 1
  vrf office
   redistribute bgp 100

router bgp 100
  vrf office
   rd 100:1
   address-family ipv4 unicast
    redistribute ospf 1 route-policy LOOPBACK
route-policy LOOPBACK
   if destination in loopback then
     pass
   endif
 end-policy
prefix-set loopback
   1.1.1.1/32
 end-set
PE2
router bgp 200
  vrf office
   rd 200:1
   address-family ipv4 unicast
    redistribute static

3. ASBR之间建立VPNV4邻居

对于Option B,在ASBR上并不建立VRF,只是通过VPNV4传VPNV4路由。但是如果没有VRF路由表,ASBR会自动过滤掉不用的路由。在路由反射器上例外,因为路由反射器会保留所有的VPN路由,所以会自动关闭路由过滤这个功能。在ASBR上关闭路由过滤功能,或者是只保留一部分路由。

IOS XR 
router bgp 100
  address-family vpnv4 unicast
   retain route-target all

IOS
router bgp 65535
  no bgp default route-target filter

VPNV4路由从一个ASBR传到另一个ASBR的时候,默认下一跳是对端ASBR的更新源,对于EBGP邻居来说,也就是对端的物理接口地址。而这个互联链路的地址在AS内部是不可达的,所以这条路由传过来是AS内部是不可达的。所以,ASBR在neighbor RR的时候要用next-hop-self。这样传过来的VPNV4的路由的下一跳则为ASBR的Lo0地址,在AS内部是可达的。

router bgp 100
  neighbor 10.0.100.3
   address-family vpnv4 unicast
    next-hop-self

VPNV4 AF建立邻居的配置则是常规的,但是EBGP VPNV4的邻居建立的时候必须要加上进出的route-policy(IOS XR)。不然,默认无从EBGP邻居学到路由。

router bgp 100
  neighbor 100.200.0.2
   remote-as 200
   address-family vpnv4 unicast
    route-policy Ingress in
    route-policy Egress out

4. ASBR之间为下一跳地址分配标签

LDP默认为32位主机路由分配标签,并不会位互联链路的IP分配标签。

在IOS XR下,需要写一个对端互联地址的32位主机路由。这样LDP才会为其分配标签。

router static
  address-family ipv4 unicast
   100.200.0.2/32 GigabitEthernet0/0/0/1

在IOS下,在互联接口下配置就可以了。

interface GigabitEthernet0/1
 mpls bgp forwarding

发表评论

您的电子邮箱地址不会被公开。 必填项已用*标注